Creation:2023/12/10 16:09:49
Problem ID:2000
Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Problem Description
输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd
zxc
Sample Output
e q w
a d s
c x z
Author
lcy
Source
Solution
#include<stdio.h>
int main()
{
char a[3],t;//用一维数组存储
while(scanf("%s",&a) != EOF)//以字符串的方式按行读入
{
for(int i=0;i<=1;i++)//冒泡排序
for(int j=i+1;j<=2;j++)
{
if(a[i]>a[j])
{
t = a[i];a[i] = a[j];a[j] = t;
}
}
printf("%c %c %c\n",a[0],a[1],a[2]);
}
return 0;
}
评论 (0)